aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSteven Davies <gentoo-guru@steev.me.uk>2021-02-14 13:38:21 +0000
committerSteven Davies <gentoo-guru@steev.me.uk>2021-02-14 13:51:00 +0000
commita696d45b19a5ba8a725a314d621e2a6c167d865f (patch)
tree4bc0e3e798b0de9fe9467910cca6cc3411338ac3 /sys-fs
parentdev-python/tekore: minor version bump (diff)
downloadguru-a696d45b19a5ba8a725a314d621e2a6c167d865f.tar.gz
guru-a696d45b19a5ba8a725a314d621e2a6c167d865f.tar.bz2
guru-a696d45b19a5ba8a725a314d621e2a6c167d865f.zip
sys-fs/python-btrfs: New ebuild
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Steven Davies <gentoo-guru@steev.me.uk>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/python-btrfs/Manifest1
-rw-r--r--sys-fs/python-btrfs/metadata.xml9
-rw-r--r--sys-fs/python-btrfs/python-btrfs-12.ebuild28
3 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/python-btrfs/Manifest b/sys-fs/python-btrfs/Manifest
new file mode 100644
index 000000000..c97445d33
--- /dev/null
+++ b/sys-fs/python-btrfs/Manifest
@@ -0,0 +1 @@
+DIST python-btrfs-12.tar.gz 92369 BLAKE2B bc899900c4d436ca4ad940247ac6edc9022f09f604c4c9b78288065e8950a9ba86147d1d9992e2410edb9907a2e7748467b1ae92d33b21c6e7ab9149c84431e3 SHA512 93d7ac4b0c8cc62e5a89b0ffd269695c2c52a4111385ec00d2cb467b6d1c35e59a450c128ca4ddedf91955f51962092ec2e2431ce3d9243d25beeaa2d2ec38ac
diff --git a/sys-fs/python-btrfs/metadata.xml b/sys-fs/python-btrfs/metadata.xml
new file mode 100644
index 000000000..a4a994536
--- /dev/null
+++ b/sys-fs/python-btrfs/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo-guru@steev.me.uk</email>
+ <name>Steven Davies</name>
+ </maintainer>
+ <longdescription>A Python 3 library that provides ways to interact programmatically with an online btrfs file system. It provides a pure python shadow implementation of data structures used in btrfs together with convenient wrappers around the collection of kernel functions that are available in the btrfs kernel API. Using them, we can examine the secret inner world of a btrfs file system for educational purposes.</longdescription>
+</pkgmetadata>
diff --git a/sys-fs/python-btrfs/python-btrfs-12.ebuild b/sys-fs/python-btrfs/python-btrfs-12.ebuild
new file mode 100644
index 000000000..f61c7435f
--- /dev/null
+++ b/sys-fs/python-btrfs/python-btrfs-12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS="no"
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 module to inspect btrfs filesystems"
+HOMEPAGE="https://github.com/knorrie/python-btrfs"
+SRC_URI="https://github.com/knorrie/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ use examples && local DOCS=( README.md CHANGES examples )
+ distutils-r1_python_install_all
+}