aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2020-09-11 21:09:12 +0500
committerDenis Reva <denis7774@gmail.com>2020-09-11 21:09:12 +0500
commit1fc210e2a9094c3b3520b729252703baf67d6f89 (patch)
tree5679347bc7c09d5ce6d631512076a828711405c5 /www-apps/gogs
parentwww-apps/gogs: fixed intendations and license (diff)
downloadguru-1fc210e2a9094c3b3520b729252703baf67d6f89.tar.gz
guru-1fc210e2a9094c3b3520b729252703baf67d6f89.tar.bz2
guru-1fc210e2a9094c3b3520b729252703baf67d6f89.zip
www-apps/gogs: systemd fix
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'www-apps/gogs')
-rw-r--r--www-apps/gogs/files/systemd/gogs.service4
-rw-r--r--www-apps/gogs/gogs-0.12.1.ebuild5
2 files changed, 3 insertions, 6 deletions
diff --git a/www-apps/gogs/files/systemd/gogs.service b/www-apps/gogs/files/systemd/gogs.service
index c4648a229..014c5c8ab 100644
--- a/www-apps/gogs/files/systemd/gogs.service
+++ b/www-apps/gogs/files/systemd/gogs.service
@@ -12,7 +12,7 @@ Requires=network.target
[Service]
User=gogs
-Group=gogs
+Group=git
Environment="GOGS_WORK_DIR=/var/lib/gogs"
Environment="GOGS_CUSTOM=/etc/gogs"
@@ -21,4 +21,4 @@ ExecStart=/usr/bin/gogs web -c /etc/gogs/conf/app.ini
Restart=always
PrivateTmp=true
-Nice=5 \ No newline at end of file
+Nice=5
diff --git a/www-apps/gogs/gogs-0.12.1.ebuild b/www-apps/gogs/gogs-0.12.1.ebuild
index 702c8c552..e1584b81a 100644
--- a/www-apps/gogs/gogs-0.12.1.ebuild
+++ b/www-apps/gogs/gogs-0.12.1.ebuild
@@ -487,10 +487,7 @@ src_install() {
# Install binary
dobin gogs
# Prepare systemd init scripts and install it
- cp "${FILESDIR}/systemd/${PN}.service" "${T}/${PN}.service" || die
- use mysql && enable_systemd_dep mysqld
- use postgres && enable_systemd_dep postgresql
- systemd_dounit "${T}/${PN}.service"
+ systemd_dounit "${FILESDIR}/systemd/${PN}.service"
# Install OpenRC init files
doconfd "${FILESDIR}/gogs-confd"
doinitd "${FILESDIR}/gogs-initd"