aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-03-14 11:57:00 +0100
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-03-14 11:57:12 +0100
commit68b48e04e2f020ec1db1b4dab3948c17369c85c3 (patch)
treea73a49f096c7956cabd62f317bb9af076eca75aa /www-client/woob/woob-9999.ebuild
parentdev-python/xunitparser: New Package (test-dep of www-client/woob) (diff)
downloadguru-68b48e04e2f020ec1db1b4dab3948c17369c85c3.tar.gz
guru-68b48e04e2f020ec1db1b4dab3948c17369c85c3.tar.bz2
guru-68b48e04e2f020ec1db1b4dab3948c17369c85c3.zip
www-client/woob: New Package
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'www-client/woob/woob-9999.ebuild')
-rw-r--r--www-client/woob/woob-9999.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/www-client/woob/woob-9999.ebuild b/www-client/woob/woob-9999.ebuild
new file mode 100644
index 000000000..3cd43c639
--- /dev/null
+++ b/www-client/woob/woob-9999.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]
+then
+ EGIT_REPO_URI="https://git.weboob.org/weboob/weboob.git"
+ inherit git-r3
+else
+ SRC_URI="https://git.woob.tech/weboob/weboob/uploads/7b91875f693b60e93c5976daa051034b/weboob-2.0.tar.gz"
+ S="${WORKDIR}/weboob-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Consume lots of websites without a browser (Web Outside Of Browsers)"
+HOMEPAGE="https://woob.tech/"
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="test"
+#RESTRICT="!test ( test )"
+
+# setup.cfg + .ci/requirements.txt + .ci/requirements-module.txt
+COMMON_DEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/html2text[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+# setup.cfg + .ci/requirements.txt + .ci/requirements-module.txt
+DEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/xunitparser[${PYTHON_USEDEP}]
+ >=dev-python/coverage-5.1[${PYTHON_USEDEP}]
+
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/asttokens[${PYTHON_USEDEP}]
+
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/geopy[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/weboob.browser.browsers,/d' \
+ -e '/weboob.browser.pages,/d' \
+ setup.cfg || die "Failed removing network-dependent tests"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${PN}/
+ doins -r contrib
+}