aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfe İzbudak <efe.izbudak@metu.edu.tr>2023-07-13 09:20:09 -0400
committerEfe İzbudak <efe.izbudak@metu.edu.tr>2023-07-13 16:22:42 +0300
commit79f17c5eb9a8ec2dab9392cea0bbf26a30e0eb06 (patch)
tree6b50335da2af4b7f155f0f77f2148782f46fd125 /www-client
parentwww-client/vimb: fix DEPEND categorization (diff)
downloadguru-79f17c5eb9a8ec2dab9392cea0bbf26a30e0eb06.tar.gz
guru-79f17c5eb9a8ec2dab9392cea0bbf26a30e0eb06.tar.bz2
guru-79f17c5eb9a8ec2dab9392cea0bbf26a30e0eb06.zip
www-client/vimb: add 3.7.0
adblock feature has been disabled because it no longer works with the new version. Signed-off-by: Efe İzbudak <efe.izbudak@metu.edu.tr>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/vimb/Manifest1
-rw-r--r--www-client/vimb/vimb-3.7.0.ebuild48
-rw-r--r--www-client/vimb/vimb-9999.ebuild10
3 files changed, 53 insertions, 6 deletions
diff --git a/www-client/vimb/Manifest b/www-client/vimb/Manifest
index a28a34d19..1393a2e30 100644
--- a/www-client/vimb/Manifest
+++ b/www-client/vimb/Manifest
@@ -1 +1,2 @@
DIST vimb-3.6.0.tar.gz 144750 BLAKE2B bb5b3244198e657af6a2591f75bb44598d1fa384843aa948f15eb186cea526776a2f2ae00d20ae9a81bd634df1c980cf2017f22f99e062d22231dd2cb1c9f3b2 SHA512 0c1a131641c47ec0dd7a5346d5e7260f85293ecc105e04e6265680c53bbbdc8d98acc4f4e11443efc4e4148aa0b77c496cf7e5f59d44857e6e612c3d4a643c8f
+DIST vimb-3.7.0.tar.gz 149769 BLAKE2B 79b9916ae6aa583147a8469d43e0f396e572d77ac02a1136c205a011341beac67028f21d0b0e38ccb7afa19e23e1bf4cd108714848ab0cc69ba7c5485f4d7bd6 SHA512 00101b799c33b7cdb91db407654cbccbf2041d06ae604541ba90806c6fa26345fbfe54fa42ad457817a186493b233e9ee24dc301eacf19d8cd15f546d87615a7
diff --git a/www-client/vimb/vimb-3.7.0.ebuild b/www-client/vimb/vimb-3.7.0.ebuild
new file mode 100644
index 000000000..23f02612f
--- /dev/null
+++ b/www-client/vimb/vimb-3.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit savedconfig flag-o-matic optfeature
+
+DESCRIPTION="A fast, lightweight, vim-like browser based on webkit"
+HOMEPAGE="https://fanglingsu.github.io/vimb/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fanglingsu/vimb.git"
+else
+ SRC_URI="https://github.com/fanglingsu/vimb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="savedconfig"
+
+DEPEND="
+ net-libs/webkit-gtk:4.1
+ x11-libs/gtk+:3
+"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ restore_config config.def.h
+}
+
+src_compile() {
+ has_version x11-libs/gtk+:3[-X,wayland] && append-cflags -DFEATURE_NO_XEMBED=1
+ emake PREFIX="/usr"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+ save_config src/config.def.h
+}
+
+pkg_postinst() {
+ optfeature "media decoding support" media-plugins/gst-plugins-libav media-libs/gst-plugins-good
+}
diff --git a/www-client/vimb/vimb-9999.ebuild b/www-client/vimb/vimb-9999.ebuild
index 5817181ab..23f02612f 100644
--- a/www-client/vimb/vimb-9999.ebuild
+++ b/www-client/vimb/vimb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic optfeature savedconfig
+inherit savedconfig flag-o-matic optfeature
DESCRIPTION="A fast, lightweight, vim-like browser based on webkit"
HOMEPAGE="https://fanglingsu.github.io/vimb/"
@@ -18,11 +18,10 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="savedconfig adblock"
+IUSE="savedconfig"
DEPEND="
- adblock? ( www-misc/wyebadblock )
- >=net-libs/webkit-gtk-2.20.0:4
+ net-libs/webkit-gtk:4.1
x11-libs/gtk+:3
"
BDEPEND="virtual/pkgconfig"
@@ -40,9 +39,8 @@ src_compile() {
src_install() {
emake PREFIX="/usr" DESTDIR="${D}" install
- save_config src/config.def.h
- use adblock && dosym /usr/lib/wyebrowser/adblock.so /usr/lib/vimb/adblock.so
einstalldocs
+ save_config src/config.def.h
}
pkg_postinst() {