aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Showers <gentoo@fictx.com>2024-02-06 13:09:53 -0500
committerDale Showers <gentoo@fictx.com>2024-02-06 13:09:53 -0500
commit8a44ab9d4f6caf09a0a7197d41c355446fa01d4d (patch)
tree73db3e8bb9bc77aac3dfcb42f9bd1a64ead1a0b7 /www-client
parentwww-client/nyxt: fix 9999 build (diff)
downloadguru-8a44ab9d4f6caf09a0a7197d41c355446fa01d4d.tar.gz
guru-8a44ab9d4f6caf09a0a7197d41c355446fa01d4d.tar.bz2
guru-8a44ab9d4f6caf09a0a7197d41c355446fa01d4d.zip
www-client/nyxt: add 3.10.0, 3.11.2
Signed-off-by: Dale Showers <gentoo@fictx.com>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/nyxt/Manifest2
-rw-r--r--www-client/nyxt/nyxt-3.10.0.ebuild87
-rw-r--r--www-client/nyxt/nyxt-3.11.2.ebuild87
3 files changed, 176 insertions, 0 deletions
diff --git a/www-client/nyxt/Manifest b/www-client/nyxt/Manifest
index c73cc5ed9..49d499b74 100644
--- a/www-client/nyxt/Manifest
+++ b/www-client/nyxt/Manifest
@@ -1,2 +1,4 @@
+DIST nyxt-3.10.0.gh.tar.xz 17692748 BLAKE2B 278fc2874194b26bf33359b5051c42844141ae2863dd06bfd4c732079de1cca15cb794304852725f2032b9d3820223b5e25cf6df63201cbba81a5917f4c70ac9 SHA512 79285e75eb896983dc4931d7802bb808f5c6f04f04a2f1c002bd72586562f35387c04416308964ce0ef6d630b0aacf21590c6625caa8cf6bf1a3396bf2e95794
+DIST nyxt-3.11.2.gh.tar.xz 18094244 BLAKE2B d1d48e2f8dbfc156cca05ce9e51386a6c3ae96b0e4f956ac140eeca6deb551be54806f4a11a910d58c40b5191bc9e3eb4e476f397b8a78c8c30daba71e606172 SHA512 4011196895af57c273e101b0a48248d30ba4e5cded1eedf1366cdef87b6a5d70f18f7c522aad7ec7776255e040a699edec637d915f5faacd27113fd39011cc83
DIST nyxt-3.8.0.gh.tar.xz 17482408 BLAKE2B 177efead60a27e3b537468afe30ce2889d6579260a5bf0b7413b0c51a8ac4c066e091418083aef702b345128b59d3f7e266d342509eaec1f45941048368466db SHA512 6898d1b4be25f9c123453816a15e2eab10b36c2a16156bae4ff3e48b02f3f4ba944a94c7b42e3221cecff572a943f7eb1b9ffd7e6c0b8f9bd7c6e95191809114
DIST nyxt-3.9.0.gh.tar.xz 17712004 BLAKE2B a799c874a4ca3ca4141a11d3211094e88f9ecd954f5220cb9a030a2d45546f841d532e087a7bdf1cb4d23532f8d0c37082eb82366c97dbc9a744b22afddea41a SHA512 f1669e02705052d5f22958b77d9489f008e90c0b5bbc216681843bb344c2b8d74753c485424a4be46a6f4ab4c12e6e6238ed663c1e5987fe5b31e3582126ebb8
diff --git a/www-client/nyxt/nyxt-3.10.0.ebuild b/www-client/nyxt/nyxt-3.10.0.ebuild
new file mode 100644
index 000000000..463f1d0ed
--- /dev/null
+++ b/www-client/nyxt/nyxt-3.10.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature xdg
+
+DESCRIPTION="Nyxt - the hacker's power-browser"
+HOMEPAGE="https://nyxt.atlas.engineer/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atlas-engineer/${PN}.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/atlas-engineer/${PN}/releases/download/${PV}/nyxt-${PV}-source-with-submodules.tar.xz -> ${PF}.gh.tar.xz"
+fi
+
+# Portage replaces the nyxt binary with scbl when stripping
+RESTRICT="mirror strip"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ gnome-base/gsettings-desktop-schemas
+ net-libs/glib-networking
+ net-libs/webkit-gtk:4.1
+ sys-libs/libfixposix
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-lisp/sbcl-2.0.0
+"
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+if [[ "${PV}" != 9999 ]]; then
+ src_unpack() {
+ mkdir "${WORKDIR}/${P}" || die
+ cd "${WORKDIR}/${P}"
+ default
+}
+
+fi
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_install(){
+ dobin "${S}/nyxt"
+
+ if [ "$(use doc)" ]
+ then
+ docinto "/usr/share/doc/${P}"
+ dodoc "${S}/manual.html"
+ fi
+
+ for icon in 16x16 32x32 128x128 256x256 512x512; do
+ newicon -s ${icon} "${S}/assets/nyxt_${icon}.png" ${PN}.png
+ done
+
+ domenu "${S}/assets/nyxt.desktop"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "for X11 clipboard support" "x11-misc/xclip"
+ optfeature "for spellchecking" "app-text/enchant"
+ optfeature "for HTML5 audio/video" "media-libs/gstreamer"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-bad"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-base"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-good"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-ugly"
+ optfeature "for HTML5 audio/video" "media-plugins/gst-plugins-libav"
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/www-client/nyxt/nyxt-3.11.2.ebuild b/www-client/nyxt/nyxt-3.11.2.ebuild
new file mode 100644
index 000000000..463f1d0ed
--- /dev/null
+++ b/www-client/nyxt/nyxt-3.11.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature xdg
+
+DESCRIPTION="Nyxt - the hacker's power-browser"
+HOMEPAGE="https://nyxt.atlas.engineer/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atlas-engineer/${PN}.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/atlas-engineer/${PN}/releases/download/${PV}/nyxt-${PV}-source-with-submodules.tar.xz -> ${PF}.gh.tar.xz"
+fi
+
+# Portage replaces the nyxt binary with scbl when stripping
+RESTRICT="mirror strip"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ gnome-base/gsettings-desktop-schemas
+ net-libs/glib-networking
+ net-libs/webkit-gtk:4.1
+ sys-libs/libfixposix
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-lisp/sbcl-2.0.0
+"
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+if [[ "${PV}" != 9999 ]]; then
+ src_unpack() {
+ mkdir "${WORKDIR}/${P}" || die
+ cd "${WORKDIR}/${P}"
+ default
+}
+
+fi
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_install(){
+ dobin "${S}/nyxt"
+
+ if [ "$(use doc)" ]
+ then
+ docinto "/usr/share/doc/${P}"
+ dodoc "${S}/manual.html"
+ fi
+
+ for icon in 16x16 32x32 128x128 256x256 512x512; do
+ newicon -s ${icon} "${S}/assets/nyxt_${icon}.png" ${PN}.png
+ done
+
+ domenu "${S}/assets/nyxt.desktop"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "for X11 clipboard support" "x11-misc/xclip"
+ optfeature "for spellchecking" "app-text/enchant"
+ optfeature "for HTML5 audio/video" "media-libs/gstreamer"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-bad"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-base"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-good"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-ugly"
+ optfeature "for HTML5 audio/video" "media-plugins/gst-plugins-libav"
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}