aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNickolas Raymond Kaczynski <nrk@disroot.org>2022-02-18 21:57:34 +0600
committerNickolas Raymond Kaczynski <nrk@disroot.org>2022-02-18 21:57:34 +0600
commitd6ed12936e59374cb1845b53516f11f2e7973d9d (patch)
treeca9c854c4dddb62c90b210e834f47b901ab3ee89 /x11-misc/xbanish/xbanish-1.8.ebuild
parentsys-boot/limine: bump to 2.85 (diff)
downloadguru-d6ed12936e59374cb1845b53516f11f2e7973d9d.tar.gz
guru-d6ed12936e59374cb1845b53516f11f2e7973d9d.tar.bz2
guru-d6ed12936e59374cb1845b53516f11f2e7973d9d.zip
x11-misc/xbanish: version bump v1.8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nickolas Raymond Kaczynski <nrk@disroot.org>
Diffstat (limited to 'x11-misc/xbanish/xbanish-1.8.ebuild')
-rw-r--r--x11-misc/xbanish/xbanish-1.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xbanish/xbanish-1.8.ebuild b/x11-misc/xbanish/xbanish-1.8.ebuild
new file mode 100644
index 000000000..ef2bb8219
--- /dev/null
+++ b/x11-misc/xbanish/xbanish-1.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Banish the mouse cursor when typing, show it again when the mouse moves"
+HOMEPAGE="https://github.com/jcs/xbanish"
+
+SRC_URI="https://github.com/jcs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libXt
+"
+
+src_configure() {
+ # Makefile doesn't respect user's LDFLAGS
+ sed -i \
+ -e 's|\$(LIBS) |\$(LIBS) $(LDFLAGS) |g' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin xbanish
+ doman xbanish.1
+}