aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/vidify/Manifest2
-rw-r--r--media-video/vidify/vidify-2.1.0.ebuild (renamed from media-video/vidify/vidify-2.0.5.ebuild)19
2 files changed, 17 insertions, 4 deletions
diff --git a/media-video/vidify/Manifest b/media-video/vidify/Manifest
index a82081877..f437ef6fc 100644
--- a/media-video/vidify/Manifest
+++ b/media-video/vidify/Manifest
@@ -1 +1 @@
-DIST vidify-2.0.5.tar.gz 2331312 BLAKE2B 8d57e971efb1e23df4a5903366bc10a0a1ab6650d4a40054d650c54c2ea5a75a6b3ce1213dc58146a3d2dfa99a5e48c95f66cde3e90f3eaf3cb1b32fae054e3a SHA512 2e6139e1147b6f49dc73ed102dd63dacbbca0c2456b3f0d553b8d3f85fa872a67e083c963db41d40b008d26d09e3b9ff264a4bb033ea47fab4ed8a8fc6e2b51f
+DIST vidify-2.1.0.tar.gz 2332514 BLAKE2B c3199cd20de6e306406482a15addaf1875630c61271ea04b4a0c283d14030102eced6428e2dc8945ab482af6c81f94c51742983e9a9b6581b3aac60bd1c942f6 SHA512 e1a7d60caacd30d68fc8b1ebf3ea30a0527218257fe762989dd8ca5213beb247c300a7ffafe68554c88a1f3bb2a054a555fe15a66a727c57911f1f545e8d0297
diff --git a/media-video/vidify/vidify-2.0.5.ebuild b/media-video/vidify/vidify-2.1.0.ebuild
index 284ffc749..7432733d7 100644
--- a/media-video/vidify/vidify-2.0.5.ebuild
+++ b/media-video/vidify/vidify-2.1.0.ebuild
@@ -9,9 +9,9 @@ DISTUTILS_USE_SETUPTOOLS=rdepend
inherit eutils distutils-r1 xdg-utils
-DESCRIPTION="Watch live music videos for the songs playing on your device"
+DESCRIPTION="Watch music videos in real time for the songs playing on your device"
HOMEPAGE="https://github.com/vidify/vidify"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
@@ -31,7 +31,20 @@ RDEPEND="
mpv? ( dev-python/python-mpv[${PYTHON_USEDEP}] )
vlc? ( dev-python/python-vlc[${PYTHON_USEDEP}] )"
-# Tests work (mostly) outside of emerge, but core dump inside emerge/virtx
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # skip online test
+ rm tests/apis/test_spotify_web.py || die
+
+ # this needs dbus running
+ rm tests/apis/test_mpris.py || die
+
+ # fails to parse config for some reason
+ rm tests/test_api_and_player_data.py || die
+
+ distutils-r1_python_prepare_all
+}
pkg_postinst() {
xdg_desktop_database_update