aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/smu/smu-1.5.ebuild7
-rw-r--r--app-text/smu/smu-9999.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/app-text/smu/smu-1.5.ebuild b/app-text/smu/smu-1.5.ebuild
index dee873a6c..d926d593e 100644
--- a/app-text/smu/smu-1.5.ebuild
+++ b/app-text/smu/smu-1.5.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit toolchain-funcs
+
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Gottox/${PN}.git"
@@ -17,9 +19,14 @@ HOMEPAGE="https://github.com/Gottox/smu"
LICENSE="MIT"
SLOT="0"
+pkg_setup() {
+ export CC="$(tc-getCC)"
+}
+
src_prepare() {
default
sed -i \
+ -e '/^CC/d' \
-e '/^CFLAGS/ s|-g -O0 ||;s|-Werror ||;s|^CFLAGS =|CFLAGS +=|;' \
-e '/^LDFLAGS/ s|^LDFLAGS =|LDFLAGS +=|' \
config.mk || die "sed failed"
diff --git a/app-text/smu/smu-9999.ebuild b/app-text/smu/smu-9999.ebuild
index 72ebfc1d5..318067044 100644
--- a/app-text/smu/smu-9999.ebuild
+++ b/app-text/smu/smu-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit toolchain-funcs
+
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Gottox/smu.git"
@@ -17,9 +19,14 @@ HOMEPAGE="https://github.com/Gottox/smu"
LICENSE="MIT"
SLOT="0"
+pkg_setup() {
+ export CC="$(tc-getCC)"
+}
+
src_prepare() {
default
sed -i \
+ -e '/^CC/d' \
-e '/^CFLAGS/ s|-g -O0 ||;s|-Werror ||;s|^CFLAGS =|CFLAGS +=|;' \
-e '/^LDFLAGS/ s|^LDFLAGS =|LDFLAGS +=|' \
config.mk || die "sed failed"