aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cpufetch/cpufetch-1.00.ebuild')
-rw-r--r--app-misc/cpufetch/cpufetch-1.00.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/cpufetch/cpufetch-1.00.ebuild b/app-misc/cpufetch/cpufetch-1.00.ebuild
new file mode 100644
index 000000000..4da777c47
--- /dev/null
+++ b/app-misc/cpufetch/cpufetch-1.00.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simplistic yet fancy CPU architecture fetching tool"
+HOMEPAGE="https://github.com/Dr-Noob/cpufetch"
+SRC_URI="https://github.com/Dr-Noob/cpufetch/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_prepare() {
+ default
+ export CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ newdoc README.md README
+ dodoc -r doc/.
+}