aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cpufetch/files/cpufetch-0.98-makefile.patch')
-rw-r--r--app-misc/cpufetch/files/cpufetch-0.98-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/cpufetch/files/cpufetch-0.98-makefile.patch b/app-misc/cpufetch/files/cpufetch-0.98-makefile.patch
new file mode 100644
index 0000000000..16180c59e5
--- /dev/null
+++ b/app-misc/cpufetch/files/cpufetch-0.98-makefile.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,4 @@
+-CC ?= gcc
+-
+-CFLAGS+=-Wall -Wextra -pedantic -fstack-protector-all -pedantic -std=c99
++CFLAGS+=-Wall -Wextra -pedantic -std=c99
+ SANITY_FLAGS=-Wfloat-equal -Wshadow -Wpointer-arith
+
+ PREFIX ?= /usr
+@@ -35,17 +33,15 @@
+ OUTPUT=cpufetch.exe
+ endif
+
+-all: CFLAGS += -O3
+ all: $(OUTPUT)
+
+-debug: CFLAGS += -g -O0
+ debug: $(OUTPUT)
+
+-static: CFLAGS += -static -O3
++static: CFLAGS += -static
+ static: $(OUTPUT)
+
+ $(OUTPUT): Makefile $(SOURCE) $(HEADERS)
+- $(CC) $(CFLAGS) $(SANITY_FLAGS) $(SOURCE) -o $(OUTPUT)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(SANITY_FLAGS) $(SOURCE) -o $(OUTPUT)
+
+ run: $(OUTPUT)
+ ./$(OUTPUT)