aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/nonsense/nonsense-0.7.ebuild')
-rw-r--r--app-misc/nonsense/nonsense-0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/nonsense/nonsense-0.7.ebuild b/app-misc/nonsense/nonsense-0.7.ebuild
new file mode 100644
index 0000000000..4874390fca
--- /dev/null
+++ b/app-misc/nonsense/nonsense-0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+COMMIT="766d34590e1fc0edddb381ad16fab57f5d20d299"
+
+DESCRIPTION="Generates random text from datafiles and templates"
+HOMEPAGE="
+ https://github.com/aduial/nonsense
+ https://nonsense.sourceforge.net
+"
+SRC_URI="https://github.com/aduial/nonsense/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_install() {
+ newbin nonsense.pl nonsense
+ dodoc README.md CHANGELOG.md HOWTO.md
+ insinto /usr/share/nonsense
+ doins *.data *.html *.template
+}