aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/telegram-send/telegram-send-0.25.ebuild')
-rw-r--r--app-misc/telegram-send/telegram-send-0.25.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/telegram-send/telegram-send-0.25.ebuild b/app-misc/telegram-send/telegram-send-0.25.ebuild
new file mode 100644
index 0000000000..f762d1414d
--- /dev/null
+++ b/app-misc/telegram-send/telegram-send-0.25.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Send messages and files over Telegram from the command-line."
+HOMEPAGE="https://www.rahielkasim.com/telegram-send/"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/python-telegram-bot[${PYTHON_USEDEP}]
+"