aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/watchexec/watchexec-1.15.3.ebuild')
-rw-r--r--app-misc/watchexec/watchexec-1.15.3.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/app-misc/watchexec/watchexec-1.15.3.ebuild b/app-misc/watchexec/watchexec-1.15.3.ebuild
new file mode 100644
index 000000000..eadc24d8e
--- /dev/null
+++ b/app-misc/watchexec/watchexec-1.15.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2017-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Auto-Generated by cargo-ebuild 0.3.1
+
+EAPI=7
+
+CRATES="
+aho-corasick-0.7.15
+bitflags-1.2.1
+bstr-0.2.15
+cc-1.0.67
+cfg-if-0.1.10
+cfg-if-1.0.0
+clap-2.33.3
+darling-0.12.4
+darling_core-0.12.4
+darling_macro-0.12.4
+derive_builder-0.10.2
+derive_builder_core-0.10.2
+derive_builder_macro-0.10.2
+embed-resource-1.6.2
+env_logger-0.8.3
+filetime-0.2.14
+fnv-1.0.7
+fsevent-0.4.0
+fsevent-sys-2.0.1
+fuchsia-zircon-0.3.3
+fuchsia-zircon-sys-0.3.3
+glob-0.3.0
+globset-0.4.6
+ident_case-1.0.1
+inotify-0.7.1
+inotify-sys-0.1.5
+iovec-0.1.4
+kernel32-sys-0.2.2
+lazy_static-1.4.0
+lazycell-1.3.0
+libc-0.2.93
+log-0.4.14
+memchr-2.3.4
+mio-0.6.23
+mio-extras-2.0.6
+miow-0.2.2
+net2-0.2.37
+nix-0.20.0
+notify-4.0.16
+proc-macro2-1.0.26
+quote-1.0.9
+redox_syscall-0.2.6
+regex-1.4.6
+regex-syntax-0.6.23
+same-file-1.0.6
+slab-0.4.3
+strsim-0.10.0
+syn-1.0.70
+term_size-0.3.2
+textwrap-0.11.0
+unicode-width-0.1.8
+unicode-xid-0.2.1
+vswhom-0.1.0
+vswhom-sys-0.1.0
+walkdir-2.3.2
+winapi-0.2.8
+winapi-0.3.9
+winapi-build-0.1.1
+winapi-i686-pc-windows-gnu-0.4.0
+winapi-util-0.1.5
+winapi-x86_64-pc-windows-gnu-0.4.0
+winreg-0.8.0
+ws2_32-sys-0.2.1
+"
+
+inherit cargo
+
+DESCRIPTION="Executes commands in response to file modifications"
+HOMEPAGE="https://github.com/watchexec/watchexec"
+SRC_URI="https://github.com/watchexec/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" $(cargo_crate_uris ${CRATES})"
+# Prevent portage from trying to fetch bunch of *.crate from mirror despite they are not mirrored.
+RESTRICT="mirror"
+LICENSE="Apache-2.0 BSD CC0-1.0 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+QA_FLAGS_IGNORED="usr/bin/watchexec"
+
+src_install() {
+ cargo_src_install
+
+ dodoc README.md doc/watchexec.1.html
+ doman doc/watchexec.1
+
+ insinto /usr/share/zsh/site-functions
+ newins completions/zsh _watchexec
+}