aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/smu/smu-9999.ebuild')
-rw-r--r--app-text/smu/smu-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/smu/smu-9999.ebuild b/app-text/smu/smu-9999.ebuild
new file mode 100644
index 000000000..72ebfc1d5
--- /dev/null
+++ b/app-text/smu/smu-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Gottox/smu.git"
+else
+ SRC_URI="https://github.com/Gottox/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Simple markup - markdown like syntax"
+HOMEPAGE="https://github.com/Gottox/smu"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^CFLAGS/ s|-g -O0 ||;s|-Werror ||;s|^CFLAGS =|CFLAGS +=|;' \
+ -e '/^LDFLAGS/ s|^LDFLAGS =|LDFLAGS +=|' \
+ config.mk || die "sed failed"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" install
+ dodoc "documentation"
+}