aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/tldr/tldr-2.0.0-r1.ebuild')
-rw-r--r--app-text/tldr/tldr-2.0.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/tldr/tldr-2.0.0-r1.ebuild b/app-text/tldr/tldr-2.0.0-r1.ebuild
new file mode 100644
index 0000000000..11c11ff381
--- /dev/null
+++ b/app-text/tldr/tldr-2.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python command line client for tldr pages"
+HOMEPAGE="https://github.com/tldr-pages/tldr-python-client"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ !app-misc/tealdeer
+"