aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/blurhash/blurhash-0.2.0-r1.ebuild')
-rw-r--r--dev-cpp/blurhash/blurhash-0.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/blurhash/blurhash-0.2.0-r1.ebuild b/dev-cpp/blurhash/blurhash-0.2.0-r1.ebuild
new file mode 100644
index 000000000..2997daf14
--- /dev/null
+++ b/dev-cpp/blurhash/blurhash-0.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="C++ blurhash encoder/decoder"
+HOMEPAGE="https://nheko.im/nheko-reborn/blurhash"
+SRC_URI="https://nheko.im/nheko-reborn/${PN}/-/archive/v${PV}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Boost-1.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/doctest )"
+
+src_configure() {
+ local -a emesonargs=(
+ $(meson_use test tests)
+
+ # https://bugs.gentoo.org/921619
+ -Dexamples=true
+ )
+ meson_src_configure
+}