aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/ranch/ranch-1.7.1.ebuild')
-rw-r--r--dev-erlang/ranch/ranch-1.7.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-erlang/ranch/ranch-1.7.1.ebuild b/dev-erlang/ranch/ranch-1.7.1.ebuild
new file mode 100644
index 000000000..2e2215530
--- /dev/null
+++ b/dev-erlang/ranch/ranch-1.7.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rebar
+
+DESCRIPTION="Socket acceptor pool for TCP protocols."
+HOMEPAGE="https://github.com/ninenines/ranch"
+SRC_URI="https://github.com/ninenines/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.asciidoc )
+
+# TODO: ranch has a test suite with lots of dependencies; enable it once those
+# dependencies are merged as well
+RESTRICT=test
+
+# Override with EAPI default because it's missing ranch.app.src and doesn't
+# have any deps.
+src_prepare() {
+ default
+}