aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/randomx/randomx-1.1.9.ebuild')
-rw-r--r--dev-libs/randomx/randomx-1.1.9.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/randomx/randomx-1.1.9.ebuild b/dev-libs/randomx/randomx-1.1.9.ebuild
new file mode 100644
index 000000000..1431d2374
--- /dev/null
+++ b/dev-libs/randomx/randomx-1.1.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Proof of work algorithm based on random code execution"
+HOMEPAGE="https://github.com/tevador/RandomX"
+SRC_URI="https://github.com/tevador/RandomX/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+S="${WORKDIR}"/RandomX-${PV}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ cmake_src_configure
+}