aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/tar')
-rw-r--r--dev-ml/tar/Manifest2
-rw-r--r--dev-ml/tar/metadata.xml25
-rw-r--r--dev-ml/tar/tar-1.1.0.ebuild63
-rw-r--r--dev-ml/tar/tar-2.0.1.ebuild63
4 files changed, 0 insertions, 153 deletions
diff --git a/dev-ml/tar/Manifest b/dev-ml/tar/Manifest
deleted file mode 100644
index bfbe50b95..000000000
--- a/dev-ml/tar/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST tar-1.1.0.tar.gz 24429 BLAKE2B 778f77f650c775e22cfd71741ce3b0aa5e75026c4be697c3d9d5532407c07f68c59700a78eff5c48bcfefa6db7b5116fed3d9c0bba708bb94b5cce41bea5dbbe SHA512 d02a5c2bef9a77b2bb32f7f85d741eb58d42ffcff916a3cfe618ff4b372d72e53176dfc050e876efcbbaf5057aa21b5615e99ebb435eb63aa10815b0ce102ba7
-DIST tar-2.0.1.tar.gz 26751 BLAKE2B a381c258c75350198c25c105f8ca33f33dd8d946f88cb102186ece414def2fa5e25191c2ed43d5d0e9286a0bc352ffec8b6999d17f18479642900b59f4d1cc17 SHA512 fd2e302497eb673a4e8000d0bcfd9012b1f118021e1d071a7c56cc6652ec6da9c6f755c18aa4b275daf1f722409d71cbb4519285096682344bfa65bbe800cbd1
diff --git a/dev-ml/tar/metadata.xml b/dev-ml/tar/metadata.xml
deleted file mode 100644
index 5fcfae03a..000000000
--- a/dev-ml/tar/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <use>
- <flag name="mirage">Read and write tar format files via MirageOS interfaces</flag>
- <flag name="unix">Decode and encode tar format files from Unix</flag>
- </use>
- <longdescription lang="en">tar is a simple library to read and write tar files with an emphasis on
-streaming.
-
-This is pure OCaml code, no C bindings.</longdescription>
- <upstream>
- <doc>https://mirage.github.io/ocaml-tar/</doc>
- <bugs-to>https://github.com/mirage/ocaml-tar/issues</bugs-to>
- <remote-id type="github">mirage/ocaml-tar</remote-id>
- <maintainer>
- <name>David Scott</name>
- <email>dave@recoil.org</email>
- </maintainer>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ml/tar/tar-1.1.0.ebuild b/dev-ml/tar/tar-1.1.0.ebuild
deleted file mode 100644
index 4102ea677..000000000
--- a/dev-ml/tar/tar-1.1.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune multiprocessing
-
-MYPN="ocaml-${PN}"
-
-DESCRIPTION="Pure OCaml library to read and write tar files"
-HOMEPAGE="
- https://github.com/mirage/ocaml-tar
- https://opam.ocaml.org/packages/tar/
-"
-SRC_URI="https://github.com/mirage/${MYPN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MYPN}-${PV}"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="mirage ocamlopt test unix"
-
-RDEPEND="
- dev-ml/camlp-streams:=
- dev-ml/cstruct:=
- dev-ml/re:=
- dev-ml/lwt:=
-
- mirage? (
- dev-ml/io-page:=
- dev-ml/mirage-block:=
- dev-ml/mirage-kv:=
- dev-ml/ptime:=
- )
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-ml/mirage-block-unix
- dev-ml/ounit2
- )
-"
-
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- test? ( mirage unix )
-"
-
-src_compile() {
- local pkgs="tar"
- for u in mirage unix ; do
- if use ${u} ; then
- pkgs="${pkgs},tar-${u}"
- fi
- done
- dune build -p "${pkgs}" -j $(makeopts_jobs) || die
-}
-
-src_install() {
- dune_src_install tar
- use mirage && dune_src_install tar-mirage
- use unix && dune_src_install tar-unix
-}
diff --git a/dev-ml/tar/tar-2.0.1.ebuild b/dev-ml/tar/tar-2.0.1.ebuild
deleted file mode 100644
index 4102ea677..000000000
--- a/dev-ml/tar/tar-2.0.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune multiprocessing
-
-MYPN="ocaml-${PN}"
-
-DESCRIPTION="Pure OCaml library to read and write tar files"
-HOMEPAGE="
- https://github.com/mirage/ocaml-tar
- https://opam.ocaml.org/packages/tar/
-"
-SRC_URI="https://github.com/mirage/${MYPN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MYPN}-${PV}"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="mirage ocamlopt test unix"
-
-RDEPEND="
- dev-ml/camlp-streams:=
- dev-ml/cstruct:=
- dev-ml/re:=
- dev-ml/lwt:=
-
- mirage? (
- dev-ml/io-page:=
- dev-ml/mirage-block:=
- dev-ml/mirage-kv:=
- dev-ml/ptime:=
- )
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-ml/mirage-block-unix
- dev-ml/ounit2
- )
-"
-
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- test? ( mirage unix )
-"
-
-src_compile() {
- local pkgs="tar"
- for u in mirage unix ; do
- if use ${u} ; then
- pkgs="${pkgs},tar-${u}"
- fi
- done
- dune build -p "${pkgs}" -j $(makeopts_jobs) || die
-}
-
-src_install() {
- dune_src_install tar
- use mirage && dune_src_install tar-mirage
- use unix && dune_src_install tar-unix
-}