aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/TakeTheTime/TakeTheTime-0.3.1.ebuild')
-rw-r--r--dev-python/TakeTheTime/TakeTheTime-0.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/TakeTheTime/TakeTheTime-0.3.1.ebuild b/dev-python/TakeTheTime/TakeTheTime-0.3.1.ebuild
new file mode 100644
index 000000000..900821987
--- /dev/null
+++ b/dev-python/TakeTheTime/TakeTheTime-0.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1
+
+DESCRIPTION="Take The Time, a super-neat Python library for timing chunks of code"
+HOMEPAGE="https://github.com/ErikBjare/TakeTheTime"
+
+# pypi doesn't contains the tests
+SRC_URI="https://github.com/ErikBjare/TakeTheTime/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests
+}