aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiomysql/aiomysql-0.0.20.ebuild')
-rw-r--r--dev-python/aiomysql/aiomysql-0.0.20.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/dev-python/aiomysql/aiomysql-0.0.20.ebuild b/dev-python/aiomysql/aiomysql-0.0.20.ebuild
index bcc14bedc..e84e16784 100644
--- a/dev-python/aiomysql/aiomysql-0.0.20.ebuild
+++ b/dev-python/aiomysql/aiomysql-0.0.20.ebuild
@@ -3,16 +3,16 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
DESCRIPTION="aiomysql is a library for accessing a MySQL database from the asyncio"
HOMEPAGE="
- https://aiomysql.readthedocs.io/en/latest/
- https://github.com/aio-libs/aiomysql
+ https://aiomysql.readthedocs.io/en/latest/
+ https://github.com/aio-libs/aiomysql
"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -20,12 +20,19 @@ KEYWORDS="~amd64 ~x86"
RDEPEND=">=dev-python/pymysql-0.9.0[${PYTHON_USEDEP}]"
-DEPEND="test? ( dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/uvloop[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/docker-py[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # fails: lots of AttributeError
+ rm tests/conftest.py || die
+
+ distutils-r1_python_prepare_all
+}
distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinxcontrib-asyncio