aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/almost/almost-0.1.5.ebuild')
-rw-r--r--dev-python/almost/almost-0.1.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/almost/almost-0.1.5.ebuild b/dev-python/almost/almost-0.1.5.ebuild
new file mode 100644
index 000000000..ff43a4ae9
--- /dev/null
+++ b/dev-python/almost/almost-0.1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+COMMIT="cc3eeb0abde7ff95a222d571443989c74a112ff7"
+
+DESCRIPTION="A helper for approximate comparison"
+HOMEPAGE="
+ https://github.com/sublee/almost
+ https://pypi.org/project/almost
+"
+SRC_URI="https://github.com/sublee/almost/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+#no tests in pypi tarball
+distutils_enable_tests setup.py
+
+src_prepare() {
+ sed -i "s|distribute|setuptools|" setup.py || die
+ default
+}