aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/azure-storage-blob/azure-storage-blob-12.16.0.ebuild')
-rw-r--r--dev-python/azure-storage-blob/azure-storage-blob-12.16.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/azure-storage-blob/azure-storage-blob-12.16.0.ebuild b/dev-python/azure-storage-blob/azure-storage-blob-12.16.0.ebuild
new file mode 100644
index 000000000..10b7e8ca4
--- /dev/null
+++ b/dev-python/azure-storage-blob/azure-storage-blob-12.16.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Microsoft Azure Blob Storage Client Library for Python"
+HOMEPAGE="
+ https://pypi.org/project/azure-storage-blob/
+ https://github.com/Azure/azure-sdk-for-python
+"
+SRC_URI="$(pypi_sdist_url --no-normalize ${PN} ${PV} .zip)"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/azure-core-1.24.2[${PYTHON_USEDEP}]
+ <dev-python/azure-core-2.0.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/msrest[${PYTHON_USEDEP}]
+"
+BDEPEND="app-arch/unzip"
+# TODO: package azure-sdk-tools (https://github.com/Azure/azure-sdk-for-python/tree/main/tools/azure-sdk-tools)
+#BDEPEND="
+# app-arch/unzip
+# test? (
+# dev-python/aiohttp[${PYTHON_USEDEP}]
+# dev-python/azure-sdk-tools[${PYTHON_USEDEP}]
+# dev-python/requests[${PYTHON_USEDEP}]
+# )
+#"
+
+DOCS=( {CHANGELOG,README,migration_guide}.md )
+
+distutils_enable_tests pytest