aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/colorthief/colorthief-0.2.1.ebuild')
-rw-r--r--dev-python/colorthief/colorthief-0.2.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/colorthief/colorthief-0.2.1.ebuild b/dev-python/colorthief/colorthief-0.2.1.ebuild
new file mode 100644
index 000000000..adf8f29b6
--- /dev/null
+++ b/dev-python/colorthief/colorthief-0.2.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module for grabbing the color palette from an image"
+HOMEPAGE="
+ https://github.com/fengsp/color-thief-py
+ https://pypi.org/project/colorthief/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"