aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/convertdate/convertdate-2.4.0.ebuild')
-rw-r--r--dev-python/convertdate/convertdate-2.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/convertdate/convertdate-2.4.0.ebuild b/dev-python/convertdate/convertdate-2.4.0.ebuild
new file mode 100644
index 000000000..a68be7af6
--- /dev/null
+++ b/dev-python/convertdate/convertdate-2.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Utils for converting between date formats and calculating holidays"
+HOMEPAGE="https://github.com/fitnr/convertdate"
+SRC_URI="https://github.com/fitnr/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pymeeus[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme