aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/daiquiri')
-rw-r--r--dev-python/daiquiri/Manifest1
-rw-r--r--dev-python/daiquiri/daiquiri-3.2.3.ebuild29
-rw-r--r--dev-python/daiquiri/metadata.xml16
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/daiquiri/Manifest b/dev-python/daiquiri/Manifest
new file mode 100644
index 000000000..bc3a90ff6
--- /dev/null
+++ b/dev-python/daiquiri/Manifest
@@ -0,0 +1 @@
+DIST daiquiri-3.2.3.tar.gz 19582 BLAKE2B 105ba4b80a405bcf0d64fcde585ab0cad4ab939d7d7048dba87f8f022d5bcf8e1708554459dba550765e2110e8987a4e26992d5c53db46b320a942b467d9b44e SHA512 a801e04f67340ed047322bdc65be97a463d268f26dd44615d7a4f17ca3de7c36bb244f6bd54e33c1c2055667f0b4086d98bcbf6778bc4eb99c08a657d6abd7b6
diff --git a/dev-python/daiquiri/daiquiri-3.2.3.ebuild b/dev-python/daiquiri/daiquiri-3.2.3.ebuild
new file mode 100644
index 000000000..c2df3bdf6
--- /dev/null
+++ b/dev-python/daiquiri/daiquiri-3.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to configure Python logging easily"
+HOMEPAGE="
+ https://pypi.org/project/daiquiri/
+ https://github.com/Mergifyio/daiquiri
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/python-json-logger[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx doc/source
+
+pkg_postinst() {
+ optfeature "journald support" dev-python/python-systemd
+}
diff --git a/dev-python/daiquiri/metadata.xml b/dev-python/daiquiri/metadata.xml
new file mode 100644
index 000000000..7251a0c50
--- /dev/null
+++ b/dev-python/daiquiri/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+The daiquiri library provides an easy way to configure logging. It also provides some custom formatters and handlers.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jd/daiquiri</remote-id>
+ <remote-id type="pypi">daiquiri</remote-id>
+ <maintainer>
+ <name>Julien Danjou</name>
+ <email>julien@danjou.info</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>