aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild')
-rw-r--r--dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild b/dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild
new file mode 100644
index 000000000..5ad16b998
--- /dev/null
+++ b/dev-python/desktop-notifier/desktop-notifier-3.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="desktop-notifier is a Python library for cross-platform desktop notifications"
+HOMEPAGE="
+ https://desktop-notifier.readthedocs.io
+ https://pypi.org/project/desktop-notifier
+ https://github.com/samschott/desktop-notifier
+"
+SRC_URI="https://github.com/samschott/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dbus-next[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
+"
+
+distutils_enable_sphinx docs