aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/factory-boy/factory-boy-3.2.1-r1.ebuild')
-rw-r--r--dev-python/factory-boy/factory-boy-3.2.1-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/factory-boy/factory-boy-3.2.1-r1.ebuild b/dev-python/factory-boy/factory-boy-3.2.1-r1.ebuild
deleted file mode 100644
index 198eebe42..000000000
--- a/dev-python/factory-boy/factory-boy-3.2.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi
-
-DESCRIPTION="A versatile test fixtures replacement based on thoughtbot's factory_bot for Ruby"
-HOMEPAGE="
- https://pypi.org/project/factory-boy/
- https://github.com/FactoryBoy/factory_boy
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/Faker[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/django[sqlite,${PYTHON_USEDEP}]
- dev-python/pillow[jpeg,${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_IGNORE=(
- # depends on treecleaned dev-python/mongoengine
- tests/test_mongoengine.py
-)
-
-EPYTEST_DESELECT=(
- # broken
- examples/flask_alchemy
-)
-
-distutils_enable_tests pytest
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme \
- dev-python/sphinxcontrib-spelling