aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gemcall/gemcall-0.9.1.ebuild')
-rw-r--r--dev-python/gemcall/gemcall-0.9.1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/gemcall/gemcall-0.9.1.ebuild b/dev-python/gemcall/gemcall-0.9.1.ebuild
new file mode 100644
index 000000000..7d17c0cea
--- /dev/null
+++ b/dev-python/gemcall/gemcall-0.9.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="A library and CLI tool for making gemini requests"
+HOMEPAGE="https://notabug.org/tinyrabbit/gemcall/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]"