aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/http-ece/http-ece-1.2.0.ebuild')
-rw-r--r--dev-python/http-ece/http-ece-1.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/http-ece/http-ece-1.2.0.ebuild b/dev-python/http-ece/http-ece-1.2.0.ebuild
new file mode 100644
index 000000000..1b66fed68
--- /dev/null
+++ b/dev-python/http-ece/http-ece-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+MY_PN="encrypted-content-encoding"
+DESCRIPTION="Encrypted Content Encoding for HTTP"
+HOMEPAGE="
+ https://pypi.org/project/http-ece/
+ https://github.com/web-push-libs/encrypted-content-encoding
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# dev-python/nose removed from ::gentoo
+RESTRICT="test"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]"
+
+# distutils_enable_tests nose