aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hwi')
-rw-r--r--dev-python/hwi/Manifest2
-rw-r--r--dev-python/hwi/hwi-1.2.1.ebuild56
-rw-r--r--dev-python/hwi/hwi-2.0.2.ebuild56
-rw-r--r--dev-python/hwi/metadata.xml11
4 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/hwi/Manifest b/dev-python/hwi/Manifest
deleted file mode 100644
index b46b59def..000000000
--- a/dev-python/hwi/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST hwi-1.2.1.tar.gz 200755 BLAKE2B b426dcd78f0ff6039541b768155a0be11f591ee4e72957fce16ffd26841cd92c3e80ce57daefc531c31f912ec94139f53db8823a3fadf347f0153c1d47f1ad08 SHA512 b8cdda0ce9d4d9734e2754a47343fa7f331f55c609448561b1bed304629b6f01d80dadba55193633ad6ac1a8ba595f4574ae8aa32cfc841c34cbeff315310071
-DIST hwi-2.0.2.tar.gz 2777606 BLAKE2B eacdf86c96f9123a3fef08f349a9540669dc3d304d8ef3d5c0c37baf923ec31265c1de4e8b9e68cf377ebaf212bd6b6abf935d9050b26955b335db6f3edf6126 SHA512 6c415d0ac3a673e38c87c8d9d64e789743226beff8c0148d2df3d5fc504ccce40159ddf190c1158d19f9adff4ce8ac7cf1b2ed654b1a9b9dd42181677d9823f2
diff --git a/dev-python/hwi/hwi-1.2.1.ebuild b/dev-python/hwi/hwi-1.2.1.ebuild
deleted file mode 100644
index 6aa2f6e77..000000000
--- a/dev-python/hwi/hwi-1.2.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 udev
-
-DESCRIPTION="Library and command line tool for interacting with hardware wallets"
-HOMEPAGE="https://github.com/bitcoin-core/HWI"
-
-MY_PN="HWI"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="https://github.com/bitcoin-core/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="udev doc"
-
-BDEPEND=""
-RDEPEND="
- >=dev-python/bitbox02-4.1.0[${PYTHON_USEDEP}]
- >=dev-python/ecdsa-0.13.0[${PYTHON_USEDEP}]
- >=dev-python/hidapi-0.7.99[${PYTHON_USEDEP}]
- >=dev-python/libusb1-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/mnemonic-0.18.0[${PYTHON_USEDEP}]
- >=dev-python/pyaes-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-3.7.4.1[${PYTHON_USEDEP}]"
-
-distutils_enable_tests unittest
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # remove upper bounds on dependencies from setup.py file
- sed 's/,<[0-9.]\+//' -i setup.py || die "sed failed"
-
- pushd test
- # remove tests that require hardware emulation
- rm test_coldcard.py test_device.py test_digitalbitbox.py test_keepkey.py test_ledger.py test_trezor.py
- # remove udev tests because it expects the rules are installed in the libs folder
- rm test_udevrules.py
- popd
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use udev && udev_dorules hwilib/udev/*.rules
- use doc && dodoc -r docs
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/hwi/hwi-2.0.2.ebuild b/dev-python/hwi/hwi-2.0.2.ebuild
deleted file mode 100644
index 6c009aed2..000000000
--- a/dev-python/hwi/hwi-2.0.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 udev
-
-DESCRIPTION="Library and command line tool for interacting with hardware wallets"
-HOMEPAGE="https://github.com/bitcoin-core/HWI"
-
-MY_PN="HWI"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="https://github.com/bitcoin-core/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="udev doc"
-
-BDEPEND=""
-RDEPEND="
- >=dev-python/bitbox02-5.3.0[${PYTHON_USEDEP}]
- >=dev-python/ecdsa-0.13.0[${PYTHON_USEDEP}]
- >=dev-python/hidapi-0.7.99[${PYTHON_USEDEP}]
- >=dev-python/libusb1-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/mnemonic-0.18.0[${PYTHON_USEDEP}]
- >=dev-python/pyaes-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/typing-extensions-3.7.4.1[${PYTHON_USEDEP}]"
-
-distutils_enable_tests unittest
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # remove upper bounds on dependencies from setup.py file
- sed 's/,<[0-9.]\+//' -i setup.py || die "sed failed"
-
- pushd test
- # remove tests that require hardware emulation
- rm test_coldcard.py test_device.py test_digitalbitbox.py test_keepkey.py test_ledger.py test_trezor.py
- # remove udev tests because it expects the rules are installed in the libs folder
- rm test_udevrules.py
- popd
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use udev && udev_dorules hwilib/udev/*.rules
- use doc && dodoc -r docs
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/hwi/metadata.xml b/dev-python/hwi/metadata.xml
deleted file mode 100644
index b63e8de30..000000000
--- a/dev-python/hwi/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>a.zuber@gmx.ch</email>
- <name>Andreas Zuber</name>
- </maintainer>
- <upstream>
- <remote-id type="github">bitcoin-core/HWI</remote-id>
- </upstream>
-</pkgmetadata>