aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/icecream/icecream-2.1.3.ebuild')
-rw-r--r--dev-python/icecream/icecream-2.1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/icecream/icecream-2.1.3.ebuild b/dev-python/icecream/icecream-2.1.3.ebuild
new file mode 100644
index 000000000..c00d306ea
--- /dev/null
+++ b/dev-python/icecream/icecream-2.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Pythonic task execution"
+HOMEPAGE="https://github.com/gruns/icecream https://pypi.org/project/icecream/"
+SRC_URI="https://github.com/gruns/icecream/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/executing-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/asttokens-2.0.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # Seems like those cannot work in the sandbox
+ tests/test_icecream.py::TestIceCream::testEnableDisable
+ tests/test_icecream.py::TestIceCream::testSingledispatchArgumentToString
+
+ # This one fails on Python3.12 because it is outdated
+ tests/test_icecream.py::TestIceCream::testMultilineContainerArgs
+)