aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/injector/injector-0.21.0-r1.ebuild')
-rw-r--r--dev-python/injector/injector-0.21.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/injector/injector-0.21.0-r1.ebuild b/dev-python/injector/injector-0.21.0-r1.ebuild
new file mode 100644
index 000000000..7f9655b42
--- /dev/null
+++ b/dev-python/injector/injector-0.21.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python dependency injection framework, inspired by Guice"
+HOMEPAGE="https://github.com/python-injector/injector"
+SRC_URI="
+ https://github.com/python-injector/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+}