aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/itemadapter/itemadapter-0.8.0.ebuild')
-rw-r--r--dev-python/itemadapter/itemadapter-0.8.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/itemadapter/itemadapter-0.8.0.ebuild b/dev-python/itemadapter/itemadapter-0.8.0.ebuild
new file mode 100644
index 000000000..a0e3f788c
--- /dev/null
+++ b/dev-python/itemadapter/itemadapter-0.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Common interface for scrapy data container classes"
+HOMEPAGE="https://scrapy.org/"
+SRC_URI="https://github.com/scrapy/itemadapter/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT=0
+KEYWORDS="~amd64"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${DEPEND}
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/scrapy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest