aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymeeus/pymeeus-0.5.12.ebuild')
-rw-r--r--dev-python/pymeeus/pymeeus-0.5.12.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pymeeus/pymeeus-0.5.12.ebuild b/dev-python/pymeeus/pymeeus-0.5.12.ebuild
new file mode 100644
index 000000000..aa3a9a724
--- /dev/null
+++ b/dev-python/pymeeus/pymeeus-0.5.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="PyMeeus"
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of Jean Meeus astronomical routines"
+HOMEPAGE="
+ https://pypi.org/project/PyMeeus/
+ https://github.com/architest/pymeeus
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme