aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-pkcs11')
-rw-r--r--dev-python/python-pkcs11/Manifest1
-rw-r--r--dev-python/python-pkcs11/metadata.xml30
-rw-r--r--dev-python/python-pkcs11/python-pkcs11-0.7.0-r2.ebuild65
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/python-pkcs11/Manifest b/dev-python/python-pkcs11/Manifest
deleted file mode 100644
index 662c8df3c..000000000
--- a/dev-python/python-pkcs11/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST python-pkcs11-0.7.0.tar.gz 106517 BLAKE2B ad5dde00beab92d2c530ebe0d4922a562db51b0015591d3f2dfe2f2489a01f72a8ccc4371fc0e88b2f3c8e45eb2bfc65c32c8f71dfa025f0ac9035ba2e8f2dd8 SHA512 2f8199296810c9f600012d151c42f00f9eb39dc22643a5a429f589f784fd4a14615d8b5371e175d277ea7af117d2650c1a8b69ce3c891276549c9fcb9a75229c
diff --git a/dev-python/python-pkcs11/metadata.xml b/dev-python/python-pkcs11/metadata.xml
deleted file mode 100644
index 5ec26a7dd..000000000
--- a/dev-python/python-pkcs11/metadata.xml
+++ /dev/null
@@ -1,30 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <longdescription lang="en">
-A high level, “more Pythonic” interface to the PKCS#11 (Cryptoki) standard to support HSM and Smartcard devices in Python.
-
-The interface is designed to follow the logical structure of a HSM, with useful defaults for obscurely documented parameters. Many APIs will
-optionally accept iterables and act as generators, allowing you to stream large data blocks for symmetric encryption.
-
-python-pkcs11 also includes numerous utility functions to convert between PKCS #11 data structures and common interchange formats including PKCS #1
-and X.509.
-
-python-pkcs11 is fully documented and has a full integration test suite for all features, with continuous integration against multiple HSM platforms including:
-Thales nCipher
-Opencryptoki TP
-OpenSC/Smartcard-HSM/Nitrokey HSM
- </longdescription>
- <upstream>
- <remote-id type="github">danni/python-pkcs11</remote-id>
- <remote-id type="pypi">python-pkcs11</remote-id>
- <maintainer status="unknown">
- <email>danielle@madeley.id.au</email>
- <name>Danielle Madeley</name>
- </maintainer>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/python-pkcs11/python-pkcs11-0.7.0-r2.ebuild b/dev-python/python-pkcs11/python-pkcs11-0.7.0-r2.ebuild
deleted file mode 100644
index b01bdd875..000000000
--- a/dev-python/python-pkcs11/python-pkcs11-0.7.0-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-inherit edo distutils-r1 pypi
-
-DESCRIPTION="PKCS#11 (Cryptoki) support for Python"
-HOMEPAGE="
- https://pypi.org/project/python-pkcs11/
- https://github.com/danni/python-pkcs11
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/asn1crypto-1.0.0[${PYTHON_USEDEP}]
- dev-python/cached-property[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-libs/openssl
- dev-libs/softhsm
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/oscrypto[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-distutils_enable_sphinx docs
-
-python_test() {
- cd "${S}" || die
- epytest
-}
-
-src_test() {
- local -x PKCS11_MODULE="${BROOT}/usr/$(get_libdir)/softhsm/libsofthsm2.so"
- local -x PKCS11_TOKEN_LABEL="TEST"
- local -x PKCS11_TOKEN_PIN="1234"
- local -x PKCS11_TOKEN_SO_PIN="5678"
-
- mkdir -p "${HOME}/.config/softhsm2" || die
- cat > "${HOME}/.config/softhsm2/softhsm2.conf" <<- EOF || die "Failed to create config"
- directories.tokendir = ${T}
- objectstore.backend = file
- EOF
-
- edo softhsm2-util --init-token --free \
- --label ${PKCS11_TOKEN_LABEL} \
- --pin ${PKCS11_TOKEN_PIN} \
- --so-pin ${PKCS11_TOKEN_SO_PIN}
-
- rm -r pkcs11 || die
- distutils-r1_src_test
-}