aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-vlc/python-vlc-3.0.11115.ebuild')
-rw-r--r--dev-python/python-vlc/python-vlc-3.0.11115.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-vlc/python-vlc-3.0.11115.ebuild b/dev-python/python-vlc/python-vlc-3.0.11115.ebuild
new file mode 100644
index 000000000..5e4c5139b
--- /dev/null
+++ b/dev-python/python-vlc/python-vlc-3.0.11115.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes-based bindings for libvlc"
+HOMEPAGE="https://github.com/oaubert/python-vlc
+ https://wiki.videolan.org/Python_bindings/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples"
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}