aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rectangle-packer/rectangle-packer-2.0.2.ebuild')
-rw-r--r--dev-python/rectangle-packer/rectangle-packer-2.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/rectangle-packer/rectangle-packer-2.0.2.ebuild b/dev-python/rectangle-packer/rectangle-packer-2.0.2.ebuild
new file mode 100644
index 000000000..4e4ff10d8
--- /dev/null
+++ b/dev-python/rectangle-packer/rectangle-packer-2.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_EXT=1
+
+inherit distutils-r1
+
+DESCRIPTION="Pack a set of rectangles into a bounding box with minimum area"
+
+HOMEPAGE="https://github.com/Penlect/rectangle-packer"
+SRC_URI="https://github.com/Penlect/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"