aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rstcheck/rstcheck-3.3.1.ebuild')
-rw-r--r--dev-python/rstcheck/rstcheck-3.3.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/rstcheck/rstcheck-3.3.1.ebuild b/dev-python/rstcheck/rstcheck-3.3.1.ebuild
deleted file mode 100644
index 82b2e9a49..000000000
--- a/dev-python/rstcheck/rstcheck-3.3.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Checks syntax of reStructuredText and code blocks nested within it"
-HOMEPAGE="https://github.com/myint/rstcheck"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/docutils[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/path-py[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${P}"
-
-distutils_enable_tests pytest
-
-python_test() {
- # Ignore the module from ${S}, use the one from ${BUILD_DIR}
- # Otherwise, ImportMismatchError may occur
- # https://github.com/gentoo/gentoo/pull/1622#issuecomment-224482396
- # Override pytest options to skip flake8
- pytest -vv --ignore=rst --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}