aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rstcheck/rstcheck-6.2.0.ebuild')
-rw-r--r--dev-python/rstcheck/rstcheck-6.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/rstcheck/rstcheck-6.2.0.ebuild b/dev-python/rstcheck/rstcheck-6.2.0.ebuild
new file mode 100644
index 000000000..e05ea0b86
--- /dev/null
+++ b/dev-python/rstcheck/rstcheck-6.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks syntax of reStructuredText and code blocks nested within it"
+HOMEPAGE="https://github.com/rstcheck/rstcheck"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/docutils[${PYTHON_USEDEP}]"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/path[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Ignore the module from ${S}, use the one from ${BUILD_DIR}
+ # Otherwise, ImportMismatchError may occur
+ # https://github.com/gentoo/gentoo/pull/1622#issuecomment-224482396
+ # Override pytest options to skip flake8
+ pytest -vv --ignore=rst --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}