aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sjcl/sjcl-0.2.1-r1.ebuild')
-rw-r--r--dev-python/sjcl/sjcl-0.2.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sjcl/sjcl-0.2.1-r1.ebuild b/dev-python/sjcl/sjcl-0.2.1-r1.ebuild
new file mode 100644
index 000000000..d6fd7fc16
--- /dev/null
+++ b/dev-python/sjcl/sjcl-0.2.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+MY_COMMIT="e8bdad312fa99c89c74f8651a1240afba8a9f3bd"
+
+DESCRIPTION="Decrypt and encrypt 'Stanford Javascript Crypto Library'-compatible messages"
+HOMEPAGE="https://github.com/berlincode/sjcl"
+
+# pypi tarball doesn't contains the tests
+SRC_URI="https://github.com/berlincode/sjcl/archive/${MY_COMMIT}.tar.gz -> ${PN}-${MY_COMMIT}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests setup.py
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"