aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/skia-pathops/skia-pathops-0.4.0.ebuild')
-rw-r--r--dev-python/skia-pathops/skia-pathops-0.4.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/skia-pathops/skia-pathops-0.4.0.ebuild b/dev-python/skia-pathops/skia-pathops-0.4.0.ebuild
new file mode 100644
index 000000000..96d1bc924
--- /dev/null
+++ b/dev-python/skia-pathops/skia-pathops-0.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+KEYWORDS="~amd64"
+DESCRIPTION="Python bindings for the Skia Path Ops"
+HOMEPAGE="
+ https://github.com/fonttools/skia-pathops
+ https://skia.org/dev/present/pathops
+"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ ~media-libs/skia-80:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest-cython[${PYTHON_USEDEP}]
+ dev-python/pytest-randomly[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ app-arch/unzip
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+# dev-python/setuptools_git_ls_files[${PYTHON_USEDEP}]
+
+#S="${WORKDIR}/${PN}-${MY_PV#v}"
+
+distutils_enable_tests pytest
+
+pkg_setup() {
+ export BUILD_SKIA_FROM_SOURCE=0
+}
+
+python_prepare_all() {
+ sed -e '/doctest-cython/d' -i tox.ini
+ distutils-r1_python_prepare_all
+}