aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sniffio/sniffio-1.2.0.ebuild')
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sniffio/sniffio-1.2.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
new file mode 100644
index 0000000000..ad474c26db
--- /dev/null
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sniff out which async library your code is running under"
+HOMEPAGE="
+ https://github.com/python-trio/sniffio
+ https://pypi.org/project/sniffio
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DEPEND="test? ( dev-python/curio[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio
+distutils_enable_tests pytest
+
+python_test() {
+ PYTHONPATH="${S}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}