aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/survey/survey-5.3.0.ebuild')
-rw-r--r--dev-python/survey/survey-5.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/survey/survey-5.3.0.ebuild b/dev-python/survey/survey-5.3.0.ebuild
new file mode 100644
index 000000000..5d68e2cb2
--- /dev/null
+++ b/dev-python/survey/survey-5.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A simple library for creating beautiful interactive prompts"
+HOMEPAGE="
+ https://github.com/Exahilosys/survey
+ https://pypi.org/project/survey/
+"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/Exahilosys/survey/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinx-paramlinks \
+ dev-python/sphinx-rtd-theme
+
+src_configure() {
+ distutils-r1_src_configure
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}