aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ufo2ft')
-rw-r--r--dev-python/ufo2ft/Manifest1
-rw-r--r--dev-python/ufo2ft/metadata.xml79
-rw-r--r--dev-python/ufo2ft/ufo2ft-2.31.1.ebuild41
3 files changed, 0 insertions, 121 deletions
diff --git a/dev-python/ufo2ft/Manifest b/dev-python/ufo2ft/Manifest
deleted file mode 100644
index e10072bdb..000000000
--- a/dev-python/ufo2ft/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ufo2ft-2.31.1.tar.gz 240056 BLAKE2B 95ba66be4d0104e56b82ff14e3a9065dd149790bcb488b9c37a12fa01f6462a8ecb5b3f6404e8164ecab26c03d0d8b6fb7e784ceffea5ac4667d87724c136531 SHA512 62fe53e576378b5dfaa41ecd25c068df9a5c4a168efc6619d65f4b552f06e466061443a9fab5f633877d7e7462836d0b789136cd7496dc29ed0659c5a2463911
diff --git a/dev-python/ufo2ft/metadata.xml b/dev-python/ufo2ft/metadata.xml
deleted file mode 100644
index 7a04ba8cc..000000000
--- a/dev-python/ufo2ft/metadata.xml
+++ /dev/null
@@ -1,79 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <description>co-maintainers welcome</description>
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <upstream>
- <remote-id type="github">googlefonts/ufo2ft</remote-id>
- <remote-id type="pypi">ufo2ft</remote-id>
- </upstream>
- <longdescription lang="en">
-ufo2ft ("UFO to FontTools") is a fork of ufo2fdk whose goal is to generate OpenType font binaries from UFOs without the FDK dependency.
-
-The library provides two functions, compileOTF and compileTTF, which work exactly the same way:
-
-from defcon import Font
-from ufo2ft import compileOTF
-ufo = Font('MyFont-Regular.ufo')
-otf = compileOTF(ufo)
-otf.save('MyFont-Regular.otf')
-
-In most cases, the behavior of ufo2ft should match that of ufo2fdk, whose documentation is retained below (and hopefully is still accurate).
-Naming Data
-
-As with any OpenType compiler, you have to set the font naming data to a particular standard for your naming to be set correctly. In ufo2fdk, you can get away with setting two naming attributes in your font.info object for simple fonts:
-
- familyName: The name for your family. For example, "My Garamond".
- styleName: The style name for this particular font. For example, "Display Light Italic"
-
-ufo2fdk will create all of the other naming data based on thse two fields. If you want to use the fully automatic naming system, all of the other name attributes should be set to None in your font. However, if you want to override the automated system at any level, you can specify particular naming attributes and ufo2fdk will honor your settings. You don't have to set all of the attributes, just the ones you don't want to be automated. For example, in the family "My Garamond" you have eight weights. It would be nice to style map the italics to the romans for each weight. To do this, in the individual romans and italics, you need to set the style mapping data. This is done through the styleMapFamilyName and styleMapStyleName attributes. In each of your roman and italic pairs you would do this:
-
-My Garamond-Light.ufo
-
- familyName = "My Garamond"
- styleName = "Light"
- styleMapFamilyName = "My Garamond Display Light"
- styleMapStyleName = "regular"
-
-My Garamond-Light Italic.ufo
-
- familyName = "My Garamond"
- styleName = "Display Light Italic"
- styleMapFamilyName = "My Garamond Display Light"
- styleMapStyleName = "italic"
-
-My Garamond-Book.ufo
-
- familyName = "My Garamond"
- styleName = "Book"
- styleMapFamilyName = "My Garamond Display Book"
- styleMapStyleName = "regular"
-
-My Garamond-Book Italic.ufo
-
- familyName = "My Garamond"
- styleName = "Display Book Italic"
- styleMapFamilyName = "My Garamond Display Book"
- styleMapStyleName = "italic"
-
-etc.
-
-Additionally, if you have defined any naming data, or any data for that matter, in table definitions within your font's features that data will be honored.
-Feature generation
-
-If your font's features do not contain kerning/mark/mkmk features, ufo2ft will create them based on your font's kerning/anchor data.
-
-In addition to Adobe OpenType feature files, ufo2ft also supports the MTI/Monotype format. For example, a GPOS table in this format would be stored within the UFO at data/com.github.googlei18n.ufo2ft.mtiFeatures/GPOS.mti.
-Fallbacks
-
-Most of the fallbacks have static values. To see what is set for these, look at fontInfoData.py in the source code.
-
-In some cases, the fallback values are dynamically generated from other data in the info object. These are handled internally with functions.
-Merging TTX
-
-If the UFO data directory has a com.github.fonttools.ttx folder with TTX files ending with .ttx, these will be merged in the generated font. The index TTX (generated when using using ttx -s) is not required.
- </longdescription>
-</pkgmetadata>
diff --git a/dev-python/ufo2ft/ufo2ft-2.31.1.ebuild b/dev-python/ufo2ft/ufo2ft-2.31.1.ebuild
deleted file mode 100644
index ad15e2786..000000000
--- a/dev-python/ufo2ft/ufo2ft-2.31.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="A bridge from UFOs to FontTools"
-HOMEPAGE="
- https://pypi.org/project/ufo2ft/
- https://github.com/googlefonts/ufo2ft
-"
-
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/booleanOperations-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/cffsubr-0.2.8[${PYTHON_USEDEP}]
- >=dev-python/cu2qu-1.6.7[${PYTHON_USEDEP}]
- >=dev-python/fonttools-4.39.2[${PYTHON_USEDEP}]
- >=dev-python/fs-2.2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/compreffor[${PYTHON_USEDEP}]
- dev-python/defcon[${PYTHON_USEDEP}]
- dev-python/skia-pathops[${PYTHON_USEDEP}]
- dev-python/ufoLib2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature "compreffor support" dev-python/compreffor
- optfeature "pathops support" dev-python/skia-pathops
-}