aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/uharfbuzz')
-rw-r--r--dev-python/uharfbuzz/Manifest1
-rw-r--r--dev-python/uharfbuzz/files/uharfbuzz-0.33.0-system-harfbuzz.patch36
-rw-r--r--dev-python/uharfbuzz/metadata.xml14
-rw-r--r--dev-python/uharfbuzz/uharfbuzz-0.33.0-r1.ebuild35
4 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/uharfbuzz/Manifest b/dev-python/uharfbuzz/Manifest
deleted file mode 100644
index b68ec9b56..000000000
--- a/dev-python/uharfbuzz/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST uharfbuzz-0.33.0.zip 1364513 BLAKE2B 668a9b7083d1a75c6845b2177b876447a25e28b15bc14e52518f1bf158ca4e23f01a0d42eb1aea02dce65c64496101ea00c8fd4d68e5ba7c1d149d920ba6624a SHA512 923ade6a4cefca9d1cfdee19fbf7b769480072695da67a1b6b75738172dad1c3236ff7d2263eeaeb6f08c235ff6efd952f095c63957549c589fafde31ca604eb
diff --git a/dev-python/uharfbuzz/files/uharfbuzz-0.33.0-system-harfbuzz.patch b/dev-python/uharfbuzz/files/uharfbuzz-0.33.0-system-harfbuzz.patch
deleted file mode 100644
index 29085fa14..000000000
--- a/dev-python/uharfbuzz/files/uharfbuzz-0.33.0-system-harfbuzz.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff --git a/setup.py b/setup.py
-index be115a3..ad34a47 100755
---- a/setup.py
-+++ b/setup.py
-@@ -13,7 +13,7 @@ here = os.path.abspath(os.path.dirname(__file__))
- with open(os.path.join(here, 'README.md'), encoding='utf-8') as f:
- long_description = f.read()
-
--define_macros = [('HB_NO_MT', '1'), ('HB_EXPERIMENTAL_API', '1')]
-+define_macros = [('HB_EXPERIMENTAL_API', '1')]
- linetrace = False
- if int(os.environ.get('CYTHON_LINETRACE', '0')):
- linetrace = True
-@@ -21,7 +21,7 @@ if int(os.environ.get('CYTHON_LINETRACE', '0')):
-
- extra_compile_args = []
- extra_link_args = []
--libraries = []
-+libraries = ['harfbuzz', 'harfbuzz-subset']
- if platform.system() != 'Windows':
- extra_compile_args.append('-std=c++11')
- define_macros.append(('HAVE_MMAP', '1'))
-@@ -39,12 +39,9 @@ if platform.system() == 'Darwin':
- extension = Extension(
- 'uharfbuzz._harfbuzz',
- define_macros=define_macros,
-- include_dirs=['harfbuzz/src'],
-+ include_dirs=['/usr/include/harfbuzz'],
- sources=[
- 'src/uharfbuzz/_harfbuzz.pyx',
-- 'harfbuzz/src/harfbuzz.cc',
-- 'harfbuzz/src/hb-subset-repacker.cc',
-- 'harfbuzz/src/graph/gsubgpos-context.cc',
- 'src/uharfbuzz/_draw_test_funcs.cc',
- ],
- language='c++',
diff --git a/dev-python/uharfbuzz/metadata.xml b/dev-python/uharfbuzz/metadata.xml
deleted file mode 100644
index 3340535bd..000000000
--- a/dev-python/uharfbuzz/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <description>co-maintainers welcome</description>
- <email>lssndrbarbieri@gmail.com</email>
- <name>Alessandro Barbieri</name>
- </maintainer>
- <upstream>
- <bugs-to>https://github.com/harfbuzz/uharfbuzz/issues</bugs-to>
- <remote-id type="github">harfbuzz/uharfbuzz</remote-id>
- <remote-id type="pypi">uharfbuzz</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/uharfbuzz/uharfbuzz-0.33.0-r1.ebuild b/dev-python/uharfbuzz/uharfbuzz-0.33.0-r1.ebuild
deleted file mode 100644
index bf3b81c36..000000000
--- a/dev-python/uharfbuzz/uharfbuzz-0.33.0-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi
-
-DESCRIPTION="Streamlined Cython bindings for the HarfBuzz shaping engine"
-HOMEPAGE="
- https://pypi.org/project/uharfbuzz/
- https://github.com/harfbuzz/uharfbuzz
-"
-SRC_URI="$(pypi_sdist_url ${PN} ${PV} .zip)"
-
-KEYWORDS="~amd64"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-RDEPEND=">=media-libs/harfbuzz-4.3.0:=[experimental(-)]"
-BDEPEND="
- app-arch/unzip
- >=dev-python/cython-0.28.1[${PYTHON_USEDEP}]
- >=dev-python/setuptools-scm-2.1[${PYTHON_USEDEP}]
-"
-
-PATCHES=( "${FILESDIR}/${PN}-0.33.0-system-harfbuzz.patch" )
-
-distutils_enable_tests pytest
-
-src_configure() {
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
- export USE_SYSTEM_HARFBUZZ=1
-}