aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylatex/Manifest2
-rw-r--r--dev-python/pylatex/metadata.xml9
-rw-r--r--dev-python/pylatex/pylatex-1.3.2.ebuild52
-rw-r--r--dev-python/pylatex/pylatex-1.3.3.ebuild55
4 files changed, 0 insertions, 118 deletions
diff --git a/dev-python/pylatex/Manifest b/dev-python/pylatex/Manifest
deleted file mode 100644
index 193e90575..000000000
--- a/dev-python/pylatex/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST pylatex-1.3.2.tar.gz 300576 BLAKE2B c096c3e182bdc13fc07c1c2b4bf6ce2e52c04fdd91da0c628d88b5fc1655c4236f468fb261b43882a41f38a389ebcc5c5f6248798df6a04e78b0cb9d4c12d2c4 SHA512 c2b7477e3f93f122865f8b68a4312d60b3548601040e51f6a80653bb5b2de8e516bb1f2d6b8ac48a5e0aba8d883c42c58757f6b1cffec5173e8edb071bf25351
-DIST pylatex-1.3.3.tar.gz 300639 BLAKE2B ac8fad8fa7e6e821cda168f3ae8ffb5acec21d688761b153ef2f9383b6a2f2ac7daea65f04389eb1ba3152fc50176d73cb814a78d2b5250ead2c6647eb96635a SHA512 12f51805996d84840f68844b79384ce4d2c29dde4db06f73b8887fe012abeaa4b9c5cf5e449132e626132b50ba26f014a899d548e3c0def25289671fd92e41a6
diff --git a/dev-python/pylatex/metadata.xml b/dev-python/pylatex/metadata.xml
deleted file mode 100644
index ebb4c5894..000000000
--- a/dev-python/pylatex/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-
-<pkgmetadata>
- <maintainer type="person">
- <email>ddenoncin@gmail.com</email>
- <name>David Denoncin</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/pylatex/pylatex-1.3.2.ebuild b/dev-python/pylatex/pylatex-1.3.2.ebuild
deleted file mode 100644
index fa49b27e1..000000000
--- a/dev-python/pylatex/pylatex-1.3.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="PyLaTeX"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit distutils-r1 eutils
-
-DESCRIPTION="A Python library for creating LaTeX files and snippets"
-HOMEPAGE="https://github.com/JelteF/PyLaTeX"
-SRC_URI="https://github.com/JelteF/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/ordered-set[${PYTHON_USEDEP}]
-"
-
-DEPEND="test? (
- dev-python/quantities[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- app-text/texlive
- dev-texlive/texlive-latexextra
-)"
-
-S="${WORKDIR}/${MY_P}"
-
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-distutils_enable_tests nose
-
-python_install_all() {
- if use examples ; then
- dodoc -r examples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "Optional dependencies:"
- optfeature "compiling generated files" app-text/texlive dev-texlive/texlive-latexextra
- optfeature "matplotlib support" dev-python/matplotlib
- optfeature "numpy support" dev-python/numpy
- optfeature "quantities support" dev-python/quantities
-}
diff --git a/dev-python/pylatex/pylatex-1.3.3.ebuild b/dev-python/pylatex/pylatex-1.3.3.ebuild
deleted file mode 100644
index 79de19f67..000000000
--- a/dev-python/pylatex/pylatex-1.3.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="PyLaTeX"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit distutils-r1 eutils
-
-DESCRIPTION="A Python library for creating LaTeX files and snippets"
-HOMEPAGE="https://github.com/JelteF/PyLaTeX"
-SRC_URI="https://github.com/JelteF/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/ordered-set[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
-distutils_enable_tests nose
-
-BDEPEND+="
- test? (
- ${RDEPEND}
- dev-python/quantities[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- app-text/texlive
- dev-texlive/texlive-latexextra
-)"
-
-S="${WORKDIR}/${MY_P}"
-
-python_install_all() {
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/"${PF}"/examples
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "Optional dependencies:"
- optfeature "compiling generated files" app-text/texlive dev-texlive/texlive-latexextra
- optfeature "matplotlib support" dev-python/matplotlib
- optfeature "numpy support" dev-python/numpy
- optfeature "quantities support" dev-python/quantities
-}