aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rust-analyzer-bin/rust-analyzer-bin-2021.09.06.ebuild')
-rw-r--r--dev-util/rust-analyzer-bin/rust-analyzer-bin-2021.09.06.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/rust-analyzer-bin/rust-analyzer-bin-2021.09.06.ebuild b/dev-util/rust-analyzer-bin/rust-analyzer-bin-2021.09.06.ebuild
new file mode 100644
index 0000000000..cd5368ed63
--- /dev/null
+++ b/dev-util/rust-analyzer-bin/rust-analyzer-bin-2021.09.06.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An implementation of Language Server Protocol for the Rust programming language"
+HOMEPAGE="https://rust-analyzer.github.io"
+SRC_URI="https://github.com/rust-analyzer/rust-analyzer/releases/download/2021-09-06/rust-analyzer-x86_64-unknown-linux-gnu.gz -> ${P}.gz"
+
+LICENSE="Apache-2.0 MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S=${WORKDIR}
+
+QA_FLAGS_IGNORED="usr/bin/rust-analyzer"
+
+src_install() {
+ newbin ${P} rust-analyzer
+}
+
+pkg_postinst() {
+ elog "Make sure to add your desired rust toolchain (e.g. with rustup) for rust-analyzer to work correctly"
+}