aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/cbonsai/cbonsai-1.3.1.ebuild')
-rw-r--r--games-misc/cbonsai/cbonsai-1.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-misc/cbonsai/cbonsai-1.3.1.ebuild b/games-misc/cbonsai/cbonsai-1.3.1.ebuild
new file mode 100644
index 000000000..a165c49d6
--- /dev/null
+++ b/games-misc/cbonsai/cbonsai-1.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="grow bonsai trees in your terminal"
+HOMEPAGE="https://gitlab.com/jallbrit/cbonsai"
+SRC_URI="https://gitlab.com/jallbrit/cbonsai/-/archive/v${PV}/cbonsai-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-text/scdoc
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${PN}-respect-variables.patch" )
+
+src_compile() {
+ emake cbonsai
+ emake cbonsai.1
+}
+
+src_install() {
+ PREFIX="${EPREFIX}/usr" DESTDIR="${D}" emake install
+}