aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/whysynth/whysynth-20170701_pre20180323.ebuild')
-rw-r--r--media-plugins/whysynth/whysynth-20170701_pre20180323.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-plugins/whysynth/whysynth-20170701_pre20180323.ebuild b/media-plugins/whysynth/whysynth-20170701_pre20180323.ebuild
new file mode 100644
index 000000000..ecdd0cd7b
--- /dev/null
+++ b/media-plugins/whysynth/whysynth-20170701_pre20180323.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A software synthesizer plugin for the DSSI Soft Synth Interface"
+HOMEPAGE="http://smbolton.com/whysynth.html https://github.com/smbolton/whysynth"
+WHYSYNTH_COMMIT="32e4bc73baa554bb1844b3165e657911f43f3568"
+SRC_URI="https://github.com/smbolton/${PN}/archive/${WHYSYNTH_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/dssi
+ media-libs/liblo
+ sci-libs/fftw:3.0
+ x11-libs/gtk+:2
+ media-libs/ladspa-sdk
+ media-libs/alsa-lib"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${WHYSYNTH_COMMIT}"
+
+src_prepare() {
+ ./autogen.sh
+ default
+ WANT_AUTOMAKE="1.7" eautoreconf
+}